Egoboo Community Forum

Multiplayer Graphics Bug
Page 1 of 1

Author:  Szkieletor [ Tue Feb 08, 2011 2:50 pm ]
Post subject:  Multiplayer Graphics Bug

I don't know if it has been reported yet, I haven't found it anywhere.
When I play with more than 1 character, after about a minute game shows blackscreen. Minimap is still there, debug writing is still there, and I can play. But console says "Encountered graphics bug in frame:" and debug says rendered tile: 0/something (total number of tiles in module is still displayed correctly after slash)

Bug don't exist in single player, but it occurs in multiplayer. It doesn't matter if players use camera button or no, how far away they are, etc.
It just black screens after some time.
Any way I can fix this?

Author:  Zefz [ Tue Feb 08, 2011 6:43 pm ]
Post subject: 

Hmm never heard about that one before. I cannot find your specified error message anywhere in the code.

Author:  bgbirdsey [ Tue Feb 08, 2011 9:56 pm ]
Post subject: 

The error "Encountered graphics bug in frame:" has to do with one of the character animations. Since it is happening often for you, what characters are yo using, and does it happen when you do a certain attack or action?

Author:  Zefz [ Tue Feb 08, 2011 11:22 pm ]
Post subject: 

Could be that animation bug that you fixed for 2.8.2? (the one always happening in the healer starter)

Author:  Szkieletor [ Wed Feb 09, 2011 10:51 am ]
Post subject: 

I'm playing with 2 soldiers and a G'nome.
I tried not moving for some time, nothing happened. Then I tried walking with soldier (Stybald on screen). I walked in one direction, stoped, and before animation stopped completely I walked in another direction. Nothing was happening.
Then I wanted to try attacking or dropping, so I stopped completely, letting animation end.
Screen shows what happened.
Black area under console is unrelated, I just cut out my desktop as isn't important[/spoiler]

Author:  bgbirdsey [ Wed Feb 09, 2011 10:34 pm ]
Post subject: 


I think it is a bug with the way the animation data was being loaded. This has been fixed, but it could possibly crop up randomly with certain models and certain animations. Hopefully, a new release that fixes this problem will be out soon.

Author:  Zefz [ Wed Feb 09, 2011 10:41 pm ]
Post subject: 

It seems a similar crash bug still happens in the latest revision, most often when you play with more than 1 player. As long as I play single player there is no error, but with multiplayer I get a NaN error from egoboo_math.inline

Author:  bgbirdsey [ Thu Feb 10, 2011 12:24 am ]
Post subject: 

I think it is likely a bug in the camera positioning, then.

With multiple players, the camera position is weighted by the player velocity so that you could have one player move away from the group and have the camera follow him (if no one else moves)... I bet there is a divide by zero in there?

Author:  Zefz [ Thu Feb 10, 2011 1:07 am ]
Post subject: 

That sounds very probable yes.

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group